Symptoms
Various BlackBerry 4.x tasks are failing with error like this:
Exception during execution of MPF request: 'Unknown error 0x80131500 [<response><errorContext description="Unknown error: 'BlackBerry(R) Enterprise Server User Administration Tool Version 4.1.6.5
Cause
The reason of problem is MS update KB982802 installed on MPS and BlackBerry servers. The update was released by Microsoft to eliminate vulnerability in remote procedure call that allowed remote code execution. These changes in RPC were enough to break besuseradminclient.exe in BlackBerry Enterprise Server 4.x.
See more details in the following threads:
http://www.blackberryforums.com/bes-admin-corner/236460-winxp-security-patch-982802-seems-break-besuseradminclient.html
http://www.blackberryforums.com.au/forums/general-bes-discussion/10844-windows-security-patch-ms10-066-breaks-besuseradminclient.html
This issue is relevant to BES 4.x (BES 5.x installations are not affected).
Resolution
1. Check if the BlackBerry User Administration Service is running on BlackBerry server, use the Services MMC snap-in.
2. Uninstall MS update KB982802 from MPS and BlackBerry servers and make sure it will not be installed automatically.
Additional information
See also:
- Microsoft® Remote Procedure Call (RPC) Security Patch MS10-066 and MS10-084 causes the BlackBerry® User Administration tool to stop functioning
- KB982802 (MS10-066) and KB2360937 (MS10-084) are not approved: Parallels Automation: Tested Windows Updates (year 2010)