Search Engine: Elastic

Article ID: 132517, created on Apr 16, 2018, last review on Apr 16, 2018

  • Applies to:
  • Operations Automation

Symptoms

It is impossible to create (or upgrade) an APS application instance. Provisioning "Globals" for APS application task fails with the error:

Provisioning error: Line 1: syntax error.

The endpoint has been deployed per the package guide, PHP of the required version has been installed and shows:

[root@endpoint ~]# /opt/rh/php54/root/usr/bin/php -v
PHP 5.4.40 (cli) (built: Aug 30 2016 13:52:21)
Copyright (c) 1997-2014 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2014 Zend Technologies

Cause

APS applications commonly require PHP + ioncube bundle, if the code is iocube-encrypted, but PHP is configured with no ionCube module loaded.

Resolution

Depending on the installed PHP version, add the initialization of ionCube module.

Example for PHP 5.4 as additional version:

# wget https://downloads.ioncube.com/loader_downloads/ioncube_loaders_lin_x86-64.tar.gz
# tar xzvf ioncube_loaders_lin_x86-64.tar.gz -C /opt/rh/php54/root/opt/
# chown -R root:root /opt/rh/php54/root/opt/iocube
# echo "zend_extension=/opt/rh/php54/root/opt/ioncube/ioncube_loader_lin_5.4.so" > /opt/rh/php54/root/etc/php.d/ioncube.ini
# service httpd restart

As a result, ionCube becomes available:

[root@endpoint ~]# /opt/rh/php54/root/usr/bin/php -v
PHP 5.4.40 (cli) (built: Aug 30 2016 13:52:21)
Copyright (c) 1997-2014 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2014 Zend Technologies
    with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v10.2.0, Copyright (c) 2002-2018, by ionCube Ltd.

5356b422f65bdad1c3e9edca5d74a1ae caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07

Email subscription for changes to this article
Save as PDF