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Article ID: 132505, created on Apr 12, 2018, last review on Apr 12, 2018

  • Applies to:
  • Operations Automation

Symptoms

  1. Task for upgrade APS 1.2 Application osCommerce (Site Application) failed with error, like:

    `ALTER TABLE `customers_info`
    CHANGE `password_reset_key` `password_reset_key` char(40) COLLATE utf8_unicode_ci NULL after `global_product_notifications` , ENGINE=InnoDB, DEFAULT CHARSET='utf8' ): Unknown column 'password_reset_key' in 'customers_info'`
    

    Note: The mentioned error could appear in case of upgrade osCommerce, for example, from version 2.3.3-x to version 2.3.4-x.

  2. Table password_reset_key does not contain column password_reset_key if check it with database client. For example:

    mysql> DESC `customers_info` 
    
    customers_info_id   int(11) NO  PRI     NULL    
    customers_info_date_of_last_logon   datetime    YES         NULL    
    customers_info_number_of_logons     int(5)  YES         NULL    
    customers_info_date_account_created     datetime    YES         NULL    
    customers_info_date_account_last_modified   datetime    YES         NULL    
    global_product_notifications    int(1)  YES         0   
    

Cause

Package vendor issue. Required SQL routines are missing for upgrade from particular osCommerce versions to latest available.

Resolution

Workaround:

  1. Connect to osCommerce MySQL database as DB owner/MySQL administrator.
  2. Alter database structure with following queries:

    alter table customers_info add password_reset_key char(40);
    alter table customers_info add password_reset_date datetime;
    
  3. Restart failed task for upgrade application instance from Provider Control Panel >

Please, contact Plesk to resolve the issue completely.

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