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Article ID: 132390, created on Mar 15, 2018, last review on Mar 15, 2018

  • Applies to:
  • Operations Automation

Symptoms

Office 365 synchronization fails with the following sitelog error:

DEBUG sync        : Updating DB...
ERROR flow        : Unable to prepare data for customer 287b17fd-...b0a6
System.Data.SqlClient.SqlException (0x80131904): Timeout expired.  The timeout period elapsed prior to completion of the operation or the server is not responding. ---> System.ComponentModel.Win32Exception (0x80004005): The wait operation timed out

Cause

Huge amount of unregistered users should be processed during the synchronization, but SQL timeout prevents it.

The behavior has been reported to Odin Development team as request #APSA-19616: "System.Data.SqlClient.SqlException (0x80131904): Timeout expired." sitelog error on attempt to process > 50k Users".

Resolution

Contact pta@odin.com or TAM to trace the status of the request.

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