Search Engine: Elastic

Article ID: 132241, created on Feb 14, 2018, last review on Feb 14, 2018

  • Applies to:
  • Operations Automation

Symptoms

IKARUS AV in the Cloud application. The Admin Console link does not work from CCPv2. Browser console error is:

Unable to load /aps/2/resources/fd0eea38-...-ccd48de43841/opensso/

/var/log/httpd/ssl_error_log error on the application Endpoint host:

[error] [client 192.168.12.40] PHP Fatal error:  Uncaught exception 'Exception' with message 'Declaration of App\\BaseResource::_postProcess() should be compatible with APS\\ResourceBase::_postprocess($method, $args, $response, $pending) at /var/www/html/ikarus_avic/BaseResource.php:115' in /usr/share/aps/php/aps/2/runtime.php:59\nStack trace:\n#0 /var/www/html/ikarus_avic/vendor/composer/ClassLoader.php(440): APS\\apsErrorHandler(2048, 'Declaration of ...', '/var/www/html/i...', 115, Array)\n#1 /var/www/html/ikarus_avic/vendor/composer/ClassLoader.php(440): Composer\\Autoload\\includeFile()\n#2 /var/www/html/ikarus_avic/vendor/composer/ClassLoader.php(322): Composer\\Autoload\\includeFile('/var/www/html/i...')\n#3 [internal function]: Composer\\Autoload\\ClassLoader->loadClass('App\\\\BaseResourc...')\n#4 /var/www/html/ikarus_avic/clouds.php(17): spl_autoload_call('App\\\\BaseResourc...')\n#5 {main}\n  thrown in /usr/share/aps/php/aps/2/runtime.php on line 59

Cause

Incompatible aps-php-runtime package version on the application Endpoint host. IKARUS AV in the Cloud APS package of version 1.4-17 supports aps-php-runtime-2.2-235 only.

Resolution

Install required aps-php-runtime package version.

5356b422f65bdad1c3e9edca5d74a1ae caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07

Email subscription for changes to this article
Save as PDF