Search Engine: Elastic

Article ID: 131812, created on Nov 24, 2017, last review on Nov 24, 2017

  • Applies to:
  • Operations Automation 7.2

Symptoms

Task on upgrade of application instance fails with the following output:

Network error: Connection refused. Application endpoint: 10.4.1.163. Request: POST /O365/globals/4a8a67b5-d7ee-4a06-8e54-d37c26a57cba/upgrade?version=3.2-603

Instance is deployed as Docker container. After a fraction of time container becomes available and the same request is processed (if one performs it manually right after task failure).

Log:

DBG [task:7410051:8819 p:-default-threadpool;-w:-Idle:854 pau]: c.p.p.s.e.e.ApsEndpointManagerBean Docker operation on uri 'https://10.4.1.163:2376' failed: Request error: 
com.spotify.docker.client.exceptions.DockerRequestException: 
Request error: POST https://10.4.1.163:2376/containers/a5144ed11dc1d83dc6c8daf8fc09953a14c93306bf818d5cb4b2d63a58db8c66/start: 500
        at com.spotify.docker.client.DefaultDockerClient.propagate(DefaultDockerClient.java:2084

Cause

Too loaded Docker node causes additional delays in container startup. APS-43472 is submitted to handle such situations.

Resolution

Please remove unneeded containers from Docker Endpoint node in order to free some resources. In order to acquire more details regarding APS-43472 please contact your Technical Manager or a member of Pooled Technical Associates team.

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