Search Engine: Elastic

Article ID: 131809, created on Nov 22, 2017, last review on Nov 22, 2017

  • Applies to:
  • Operations Automation 7.1

Symptoms

  1. VE console does not work:

    Session Closed. Please click on Reset Console
    
  2. Apache's error_log (/var/log/httpd/error_log) contains the errors:

    [Wed Nov 22 21:11:27 2017] [error] [client 192.0.2.2] File does not exist: /var/www/parallels/html/websocket
    [Wed Nov 22 21:12:37 2017] [error] [client 192.0.2.2] File does not exist: /var/www/parallels/html/websocket
    [Wed Nov 22 21:12:48 2017] [error] [client 192.0.2.2] File does not exist: /var/www/parallels/html/websocket
    [Wed Nov 22 21:20:59 2017] [error] [client 192.0.2.2] File does not exist: /var/www/parallels/html/websocket
    

Cause

Parameter ServerTokens set to 'OS' in global Apache configuration file:

[vz] ~:>grep ServerTokens /etc/httpd/conf/httpd.conf
ServerTokens OS

As a result of that configuration responses of web server contain the OS version which is not parsed by UI service.

Resolution

Parameter ServerTokens should be set to 'ProductOnly'.

Edit the configuration file of Apache /etc/httpd/conf/httpd.conf to 'ProductOnly':

[vz] ~:>grep ServerTokens /etc/httpd/conf/httpd.conf
ServerTokens ProductOnly

, and reload web server:

[vz] ~:>/etc/init.d/httpd reload
Reloading httpd:

5356b422f65bdad1c3e9edca5d74a1ae caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07 8c199f0ee4305da1a577740620df4a51 1941880841f714e458ae4dc3d9f3062d

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