Search Engine: Elastic

Article ID: 131802, created on Nov 21, 2017, last review on Jan 19, 2018

  • Applies to:
  • Operations Automation 7.0
  • Operations Automation 7.1

Symptoms

Office 365 synchronization fails:

Error: Value cannot be null. Parameter name: key

sitelog error can be either:

DEBUG sync: Role Company Administrator members: admin@domain.onmicrosoft.com, , anotheradmin@domain.onmicrosoft.com
ERROR flow: Unable to prepare data for customer aa0f5193-a4f3-4aeb-b466-c0c3ba0861f0
System.ArgumentNullException: Value cannot be null.
Parameter name: key
    at System.Collections.Generic.Dictionary`2.FindEntry(TKey key)
    at System.Collections.Generic.Dictionary`2.ContainsKey(TKey key)
    at Parallels.Office365.Gateway.Graph.SyncHelperImplGraph.SetAdminRoles() in c:\inetpub\wwwroot\O365\App_Code\Graph\SyncHelperImplGRAPH.cs:line 138

or:

DEBUG aps_endpoint: Company Administrator members loaded: 4.
ERROR aps_endpoint: Error occured during customer creation.
System.NullReferenceException: Object reference not set to an instance of an object.
at Parallels.Office365.Gateway.Import.CloudDataReader.<GetAdminLogin>b__5(User _) in c:\inetpub\wwwroot\O365App\App_Code\Import\CloudDataReader.cs:line 162
at System.Linq.Enumerable.FirstOrDefault[TSource](IEnumerable`1 source, Func`2 predicate)

Cause

"ObjectType": "ServicePrincipal" objects are returned upon synchronization request, but they cannot be processed.

This behavior has been reported to Odin Development team as request #APSA-19214: "synchronization error: "Error: Value cannot be null. Parameter name: key".

Resolution

Please contact pta@odin.com or TAM to trace the status of the request.

5356b422f65bdad1c3e9edca5d74a1ae caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07 8c199f0ee4305da1a577740620df4a51 1941880841f714e458ae4dc3d9f3062d 0871c0b47b3b86ae3b1af4c2942cd0ce

Email subscription for changes to this article
Save as PDF