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Article ID: 131481, created on Sep 18, 2017, last review on Sep 18, 2017

  • Applies to:
  • Operations Automation
  • Business Automation

Symptoms

When a subscription is destroyed in Billing, the operations ends successfully. However, checking the Task Manager queue in Operations, the tasks for service unprovisioning may remain in failed state. The subscription in question appears destroyed both in OA and BA.

Cause

By its design, the Odin Automation Platform performs an asynchronous pem.removeSubscription API call that is invoked on destroying a subscription, which means that the result is instance and subscription is removed, but the tasks to unprovide services are scheduled to be run in the background. It is provider's responsibility to track the tasks further.

Resolution

Monitor the Task Manager queue for failed tasks and resolve any arising issues during unprovisioning.

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