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Article ID: 131461, created on Sep 15, 2017, last review on Sep 15, 2017

  • Applies to:
  • Operations Automation

Symptoms

After the upgrade procedure to Office 365 version 16.6.4 or 17.1, while placing a new order for Office 365 service, on the stage of subdomain check, the error is faced:

AADSTS70001: Application with identifier 'bf671250-ae3f-4750-9144-7de8827ef307' was not found in the directory cb0119c9-416f-4a91-b73d-fbde5c5ab6c2

Cause

Missed upgrade step, allowing the move to new Partner Center API.

Resolution

Perform the post-upgrade reconfiguration (step 5 in the upgrade instructions):

Switch the Office 365 application from the CREST API to the Partner Center API:

  1. Create a native app in the Partner Center:

    • Log in to the Partner Center.
    • Go to Account setting > App management and click Add new native app.
    • Write down App ID of the native app.
  2. Specify App ID of the native app in the ID of Native Client for Partner Center SDK setting of your Office 365 application instance:

    • Log in to the Provider Control Panel.
    • Go to Services > Applications and click on the Office 365 application. Then, click on your Office 365 application instance.
    • Click Edit.
    • Specify App ID of the native app in the ID of Native Client for Partner Center SDK setting. Then, click Save.

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