Search Engine: Elastic

Article ID: 131262, created on Aug 8, 2017, last review on Aug 8, 2017

  • Applies to:
  • Operations Automation 6.0

Symptoms

  1. When submitting the mailbox credentials to webmail interface the error "502 Bad Gateway" is returned.

  2. The Apache error log on vendor's brand server contains the error:

    [Sun Aug 06 13:56:31 2017] [info] SSL Library Error: 336031996 error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol
    [Sun Aug 06 13:56:31 2017] [info] [client 192.0.2.2] Connection closed to child 0 with abortive shutdown (server vendorsbrand.com:443)
    [Sun Aug 06 13:56:31 2017] [error] (502)Unknown error 502: proxy: pass request body failed to 192.0.2.2:443 (wm01.mtnbusiness.cm)
    [Sun Aug 06 13:56:31 2017] [error] proxy: pass request body failed to 192.0.2.2:443 (wm01.mtnbusiness.cm) from 203.0.113.2 ()
    
  3. File /etc/hosts is configured to resolve webmail server's hostname its internal IP.

Cause

The web hosting node where the vendor's brand resides resolves webmail node's hostname server's internal IP. Apache on webmail server was not configured to respond SSL queries directed to internal IP.

Resolution

Configure branding node so that it resolves webmail's hostname its external IP.

5356b422f65bdad1c3e9edca5d74a1ae caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07 956c448bddc7e1f3585373687602379f 6f1456866eed87488c0f02b298a741c0

Email subscription for changes to this article
Save as PDF