Search Engine: Elastic

Article ID: 131077, created on Jun 27, 2017, last review on Jun 27, 2017

  • Applies to:
  • Operations Automation

Symptoms

Some DNS records were deleted inside a DNS zone from CP, but they still remain on the PowerDNS backend nodes.

There is a mismatch of TTL values between OA Management Node DB and PowerDNS DB.

Corresponding entries for DNS record deletion in /var/log/pa/core.log:

Jun  7 17:04:07.174 : DBG [task:50102137:74250 1:9708:af6fcb70 PowerDns ]: [ DNSManagement::PowerDns::PowerDns_impl::RemoveZoneRecord] PowerDNS: remove record (name=example.com, host=example.com, type=MX, data=20 antispam.test.net., ttl=60, prio=20)

And at the same time in /var/log/pdns.log:

Jun  7 17:04:13 ns1 postgres[22705]: [20-1] 2017-06-07 17:04:13 CEST powerdns LOG:  execute <unnamed>: DELETE FROM records WHERE domain_id = $1 AND name = $2 AND type = $3 AND content = $4 AND (ttl = $5 OR ttl = 0) AND prio = $6
Jun  7 17:04:13 ns1 postgres[22705]: [20-2] 2017-06-07 17:04:13 CEST powerdns DETAIL:  parameters: $1 = '452506', $2 = 'example.com', $3 = 'MX', $4 = 'antispam.test.net', $5 = '60', $6 = '10'

The actual TTL value stored in PowerDNS zone is different from 0 or 60:

powerdns=> select * from records where name ilike '%example.com%';
   id    | domain_id |             name             | type  |                                    content                                    | ttl  | prio  | change_date | disabled | ordername | auth
---------+-----------+------------------------------+-------+-------------------------------------------------------------------------------+------+-------+-------------+----------+-----------+------
...
 4868341 |    452506 | example.com                    | MX    | antispam.test.net                                                          | 3600 |    20 |             | f        |           | t
...

Cause

The behavior is recognized as a software issue POA-93821: Manually added PowerDNS records with default TTL are not deleted from PowerDNS server

Resolution

Delete the non-existent records manually from PowerDNS database:

powerdns=> begin;
powerdns=> delete from records where id = 4868341;
powerdns=> commit;

Contact TAM or pta@odin.com to trace the status of the product issue.

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