Search Engine: Elastic

Article ID: 131039, created on Jun 22, 2017, last review on Jun 22, 2017

  • Applies to:
  • Operations Automation 7.0

Symptoms

After installation of series hotfixes, some applications are no longer render corresponding tabs in CCPv1. When one tries to navigate to application via button Manage in CCPv1, the following error message is displayed:

An unforeseen error occurred

Additionally, opening of application's instances settings does not show preferences from application's UI and displays the following message instead:

Navigation doesn't contain view(s) - use auto-generated UI.

In pui.log one might see the follwing sequence:

[default task-157] DEBUG com.tbn.VarResolver - Getting var 'tenant' in scope of http://www.acronis.com/aps/cloud-backup-v1#ccp
[default task-157] DEBUG com.tbn.VarResolver - tenant found in cache
[default task-157] DEBUG com.tbn.VarResolver -  1 ms [VarResolver.evaluate(query, evaluator)]
[default task-157] DEBUG com.tbn.VarResolver - rql: 'false' gives ["false"]
...
[default task-157] DEBUG c.p.p.c.c.a.util.APS2CustomUIHelper - Navigation returned: Navigation: {context=[], items=[]}

Cause

APS application view cache is corrupted on UI host. As we may see from the sequence above, navigation variable is found in cache, but could not be further processed.

Resolution

Restart pau service on branded UI host as described in KB article.

5356b422f65bdad1c3e9edca5d74a1ae caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07 0871c0b47b3b86ae3b1af4c2942cd0ce 1941880841f714e458ae4dc3d9f3062d

Email subscription for changes to this article
Save as PDF