Search Engine: Elastic

Article ID: 130959, created on Jun 8, 2017, last review on Jun 8, 2017

  • Applies to:
  • Operations Automation 7.0

Symptoms

It is impossible to uninstall package bind9 from Operations Automation Premium management node. Corresponding event 'Package removal failed' is generated with the error message:

javax.ejb.EJBTransactionRolledbackException: Transaction rolled back

In core.log on the management node the following exception could be seen:

c.p.p.s.y.e.OperationProcessorBean Could not execute deinstalljavax.ejb.EJBException: javax.ejb.EJBTransactionRolledbackException: Transaction rolled back
        at com.parallels.pa.service.ypack.ejb.OperationProcessorBean.executeDeinstallComplete(OperationProcessorBean.java:497)

Slightly below NullPointerException could be found:

Caused by: java.lang.NullPointerException: null
        at com.parallels.pa.service.dns.ejb.DnsZoneSynchronizerBean.lambda$process$0(DnsZoneSynchronizerBean.java:127)

Cause

Several domains having Internal DNS Hosting Type are assigned to DNS server, which Provider is trying to remove.

Resolution

  1. Edit 'DNS Hosting' RT activation parameters: remove target DNS and set appropriate nameservers;
  2. Find all domains with Internal DNS Hosting Type and incorrect DNS servers;
  3. Switch these domains that have Internal DNS hosting, to external, wait for corresponding tasks "Update named..." are processed;
  4. Switch them back to internal, wait for corresponding tasks "Update named ..." are processed;
  5. Remove bind9 package.

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