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Article ID: 130935, created on Jun 7, 2017, last review on Jun 7, 2017

  • Applies to:
  • Business Automation

Symptoms

There is a payment with incorrect balance which has two documents attached - Refund and Void Check. This causes incorrect customer's balance. How could that have happened?

Cause

The issue can occur due to the bug with id #PBA-76712 ("It is possible to void sell transaction on the refunded payment").

Resolution

To correct the current documents and balance - contact payment system representatives and clarify if both void and refund were processed successfully (meaning the customer received money twice). With this information please contact Odin Technical Support Team.

To avoid the issue from reoccurring (forbid clicking Void on refunded payments) create the customization file ARDoc_PADetailList.xml:

<window id="ARDoc_PADetailList" >
 <actions>
 <constraint id="hideVoid" ele="Void">
  <hide>
  PaymentETransStatus "==" "29"
 </hide>
 </constraint>
 </actions>
</window>

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