Search Engine: Elastic

Article ID: 130933, created on Jun 6, 2017, last review on Jul 12, 2017

  • Applies to:
  • Operations Automation 7.1
  • Business Automation 7.1

Symptoms

In PCP > System > Information > Product License the following message is shown:

The Odin Automation license cannot be updated automatically: there are no updates available for the license. Try to upload the license manually from the Control Panel (go to System > Information > Product license)

The current license has no expiration date.

Cause

The Update License periodic task checks if updated license is available in the KA and upload the updated license if it exists.

If the license is about to expire (less that 9 days before the expiration date) but updated license is not available in the KA, corresponding warning is shown in the PCP.

Due to the fact the license has no explicitly stated date, the check cannot be passed successfully and the message appears.

This issue is acknowledged as POA-111180.

Resolution

As a workaround, the licenses were regenerated to have January 19, 2038 (maximal 32-bit UNIX-time value) as an expiration date.

Please, contact your Technical Account Manager or your Sales Manager to obtain a regenerated license.

Once it's received - upload it via System > Information > Product license > Upload license.

To avoid unnecessary notifications while the new license is not obtained, the Update license periodic task may be canceled.

5356b422f65bdad1c3e9edca5d74a1ae caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07 8c199f0ee4305da1a577740620df4a51 1941880841f714e458ae4dc3d9f3062d 7c0b495571a6c1bec50e4f324a20ec14 198398b282069eaf2d94a6af87dcb3ff b2c3b33425dfc50c7d41a2efaa7f84f3

Email subscription for changes to this article
Save as PDF