Search Engine: Elastic

Article ID: 130843, created on May 20, 2017, last review on May 20, 2017

  • Applies to:
  • Operations Automation 6.0

Symptoms

OA Management Node migration fails with the following error:

Starting sc AccountManagement terminate called after throwing an instance of 'std::runtime_error'
what():  Cannot dlopen /usr/local/pem/libexec/AccountManagement.so.6.0.6.147: /usr/local/pem/libexec/AccountManagement.so.6.0.6.147: undefined symbol: _ZN3SDK4User22setUserExpiredPasswordEib
[success] 0.0811

An attempt to start pem service manually fails with the same error.

poa-core package version is lower than SC version reported in the error:

[root@osscore ~]# rpm -q poa-core
poa-core-6.0.0.2938-1.i386

Cause

The behavior is acknowledged as a software issue POA-111365: Migration script uses core RPMs available on FS without any current version check

Resolution

  1. In case there are currently OA updates available to get installed - do it as the best resolution path.

  2. In case the updates are not available, it is necessary to find the up-to-date version of poa-core RPM package and install it on the Management Node:

    [root@osscore ~]# rpm -Uvh     /usr/local/pem/install/tarballs/corerpms/RHEL6/poa-core-6.0.7.769-1.i386.rpm
    Preparing...                ########################################### [100%]
    1:poa-core               ########################################### [100%]
    

    After that pem service will start successfully.

5356b422f65bdad1c3e9edca5d74a1ae caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07 956c448bddc7e1f3585373687602379f 6f1456866eed87488c0f02b298a741c0

Email subscription for changes to this article
Save as PDF