Article ID: 130784, created on May 10, 2017, last review on May 10, 2017

  • Applies to:
  • Operations Automation 7.1

Symptoms

An APS Provisioning task fails with the below error:

Internal error: SDK::Platform::blob Plesk::SaaS::SaaSManagerTasks_impl::taskExecuteWorkflow(const SDK::Platform::Properties&) : [APSC] Value of key 'original_identity_id' is required.

The task was scheduled before the OSA 7.0 > 7.1 upgrade. Prior to the upgrade it failed with a different error, after the upgrade it started failing with the error above.

Cause

The APS token structure for APS-related tasks is slightly different between OSA 7.0 and 7.1. In 7.1 it has the 'original_identity_id' property, which is not present in 7.0.

This issue is reported to the OA maintenance team as APS-41761: "ExecuteWorkflow tasks scheduled on 7.0 are failed on 7.1".

Resolution

Please contact your Account Manager or Pooled Technical Associates team (pta@odin.com) to trace the status of APS-41761.

If a workaround for the issue is required, please contact Odin technical support.

5356b422f65bdad1c3e9edca5d74a1ae caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07 8c199f0ee4305da1a577740620df4a51 1941880841f714e458ae4dc3d9f3062d

Email subscription for changes to this article
Save as PDF