Article ID: 130746, created on May 3, 2017, last review on May 4, 2017

  • Applies to:
  • Business Automation 7.0
  • Business Automation 7.1

Cause

On the installations with the Billing Application node running RHEL/CentOS 7, the To (and in some cases From) field of a notification message may remain empty and as a result, the message will not be sent.

Resolution

To fix such issue, do the following:

  1. Review the failed emails:

    • Login to Billing Provider Control Panel and go to System > Logs > Outgoing E-Mail Log.

    • Find the emails with empty "To" and "From" fields with the "Error" status.

    • Delete those that are irrelevant.
  2. Install the updated rpm with a fix for this issue:

    • Log in to the Billing Application node via ssh as root and run the following commands:

      # yum clean all
      # yum update libetpan
      
    • Ensure that the necessary package was updated. Run the following command for this purpose:

      # yum list intalled libetpan.x86_64
      

      which should print the following to display:

      Installed Packages
      libetpan.x86_64                1.6-2.el7.centos
      

      mind the version of the package: it must be 1.6-2 or greater.

    • Restart the billing service via the following command:

      # service pba restart
      
  3. Resend the remaining notifications manually.

7c0b495571a6c1bec50e4f324a20ec14 caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07 198398b282069eaf2d94a6af87dcb3ff b2c3b33425dfc50c7d41a2efaa7f84f3 c0f836394088a28cc30dd0e5fe8b600e

Email subscription for changes to this article
Save as PDF