Article ID: 130586, created on Apr 6, 2017, last review on Apr 6, 2017

  • Applies to:
  • Operations Automation 7.0

Symptoms

On any Virtuozzo hardware node, there is a large /var/log/pa/vps.log that contains records since node deployment (or OSA upgrade to 7.0 for old nodes).

[root@vz01 ~]# ls -alh /var/log/pa/vps.log
-rw-r--r-- 1 PACI PACI 4.2G Apr  6 05:57 /var/log/pa/vps.log

Cause

The issue is recognized as CCU-14729.

Resolution

There is no workaround available to enable log rotation. The issue will be addressed in the future OSA product releases.

To clean up the log manually:

  1. Stop OACI related services:

    # service PACI-vm2vf stop
    # service snmpd stop
    

    Note: while the services are stopped, all Virtual Environments on the current node will be unmanageable, provisioning to the node will also fail.

  2. Save the log for the last week and remove everything older. For example, to save the log since 01-Apr-2017:

    # awk '/^2017-04-01/,0' /var/log/pa/vps.log > /var/log/pa/vps.april.log
    # rm -rf /var/log/pa/vps.log
    # mv /var/log/pa/vps.april.log /var/log/pa/vps.log
    
  3. Start the services back:

    # service snmpd start
    # service PACI-vm2vf start
    

Search Words

not rotated

vps.log

vps.log vm2vf

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