Symptoms
During an order processing, provider switched Show Orders/Subscriptions option off in Billing.
As a result, the notification about order completion was not delivered and the corresponding CCPv2 tile is stuck:
Cause
The behavior is recognized as a software issue APS-39860: 'In Progress' on-screen notification remains forever if not removed/updated by application
Resolution
In order to remove the stuck notifications, switch the affected account to CCPv1 and back to CCPv2 at PCP > System > Settings > Enable/Disable CCP v2.