Search Engine: Elastic

Article ID: 130346, created on Feb 27, 2017, last review on Feb 27, 2017

  • Applies to:
  • Operations Automation 7.0

Symptoms

Running upgradeAPS1ToAPS2.py script for a subscription to convert it from APS 1.2 to APS 2.0 mode, the following error appears:

HTTP Error 500: Internal Server Error(Day of month is not valid for year)

In /var/log/pa/core.log the error appears as a result of a GET REST API call:

Feb 20 13:55:39.133 : ERR [rest:1546692 1:2320:845ffb70 SAAS ]: [ APSC] REST Error: GET //aps/2/resources/a43d4375-f7ab-4dfd-b270-a61c41d12bc4/licenses/ code=500: Day of month is not valid for year

Cause

Uncer certain circumstances, a race condition may occure in APS Controller processing the date/month during API calls. The issue is recognized as APS-39432 (APSC throws boost::gregorian::bad_day_of_month sporadically under load).

Resolution

Due to the nature of the issue, it is enough to re-run the operation again, the failure should not re-occur.

5356b422f65bdad1c3e9edca5d74a1ae caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07 0871c0b47b3b86ae3b1af4c2942cd0ce 1941880841f714e458ae4dc3d9f3062d

Email subscription for changes to this article
Save as PDF