Search Engine: Elastic

Article ID: 130276, created on Feb 10, 2017, last review on May 7, 2017

  • Applies to:
  • Operations Automation
  • Business Automation 7.0

Symptoms

"Provisioning "Tenant" for APS application Azure Cloud Solution Provider" task fails with the following output:

APS Application Error:
500 Internal Server Error
Body: {
"error": "unknown",
"message": "An unexpected error has occurred.",
"category": "unknown",
"context": null,
"http_request": "POST /aps/tenants to '127.0.0.1'"
}

Azure CSP Endpoint application-log contains the following error:

Response from 'GET https://api.cp.microsoft.com/12a34bc5-1a2b-12a3-a12b-1a234b567890/profiles?type=organization':
...
- body:
{..."email":null,...}
Required property 'email' expects a value but got null. Path 'items[0]', line 1, position 2089. 

Cause

Customer organization profile`s e-mail property is empty in the Microsoft Partner Center.

Resolution

Ask customer to update his organization profile and fill the e-mail property in the Microsoft Partner Center.

5356b422f65bdad1c3e9edca5d74a1ae caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07 198398b282069eaf2d94a6af87dcb3ff c0f836394088a28cc30dd0e5fe8b600e b2c3b33425dfc50c7d41a2efaa7f84f3

Email subscription for changes to this article
Save as PDF