Article ID: 130254, created on Feb 6, 2017, last review on Feb 6, 2017

  • Applies to:
  • Operations Automation 7.0

Symptoms

Task "Execute operation 'massUpdatePanelApps' ..." fails with the following error:

Last execution output

APS Application Error:
500 Internal Server Error

Cause

By its nature, massUpdatePanelApps task iterates through all Plesk in VPS subscriptions and tries to call an update operation for the PVPS APS application, which is located inside the end client's Virtual Environment. The operation does not have any effect on the actual Plesk services, it only interacts with the small OA part located inside /usr/local/aps directory (or C:\Program Files\APS for Windows).

500 Internal Server Error is shown, in case even one subscription experienced an update failure.

Resolution

  1. Find the list of subscriptions and their errors inside /var/log/pa/pvps.log (or /var/log/pvps.log for OA 6.0).

  2. Analyze and fix the cause of each error. For each individual VE, logging in and checking /usr/local/aps/<uuid>/var/log/pvps-panel.log will help to get behind the failure.

  3. Re-run the task.

Search Words

500 Internal Server Error

Execute operation 'massUpdatePanelApps' with

massUpdatePanelApps

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