Article ID: 129833, created on Nov 9, 2016, last review on Nov 9, 2016

  • Applies to:
  • Odin Business Automation Standard 4.5

Symptoms

Under Top > Commerce Director > Online Payments > Transaction Log some of the transactions made with the Eurobank 3d Secure (Cardlink) payment plug-in are in Unknown status.

The following error is shown in the DEBUG OBAS log (/var/log/hspc/hspc.log):

[2016/11/08 17:33:49] [ERROR] [13538] [HSPC::Taskman::Comm::backend_execute_task] Task #216138094 HSPC::MT::PP::PluginEngine::OP -> process_task failed miserably: HTTP::Message content must be bytes

Cause

Such behavior was classified as the software issue PBAS-30505 and will be fixed in future OBAS releases.

Please consider watching Odin public sources for information about updates in our products:

Public roadmaps for partners

Marketing news and important announces

Knowledge base, each product update comes with a corresponding KB article.

Resolution

Please download 64-bit hotfix or 32-bit hotfix depending on your OS and install it by running the commands below.

For 64-bit OS:

# rpm -Uvh hspc-plugin-pp-op-cardlink-4.5.6-55.swsoft.x86_64.rpm
# hspc-upgrade-manager --finish

For 32-bit OS:

# rpm -Uvh hspc-plugin-pp-op-cardlink-4.5.6-55.swsoft.i386.rpm
# hspc-upgrade-manager --finish

Warning: Running hspc-upgrade-manager --finish will cause OBAS downtime for several minutes.

After the hotfix is installed, please go Top > Configuration Director > Logging and Errors > Action Log > Tasks Queue and restart the failed tasks named Payment Processing: Process transaction # ...

Search Words

Eurobank 3d Secure

Transaction status Unknown

Message content must be bytes

unable to cc

cannot charge Credit card

Cardlink

624ca542e40215e6f1d39170d8e7ec75 caea8340e2d186a540518d08602aa065 400e18f6ede9f8be5575a475d2d6b0a6 70a5401e8b9354cd1d64d0346f2c4a3e

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