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Article ID: 129802, created on Nov 7, 2016, last review on Dec 20, 2016

  • Applies to:
  • Operations Automation 7.0
  • Business Automation 7.0

Symptoms

After upgrade to OSA 7 some orders fail to be provisioned, there are exceptions like:

c.p.p.s.b.e.BillingApiManagerBean PBA API method BM::AccountUpdateWithLocale failed with the following error: ERROR:  canceling statement due to statement timeout

ERROR: canceling statement due to statement timeout

ERROR (iqxmlrpc::Exception) in calling pem.addAccount: org.omg.CORBA.UNKNOWN: Server-side Exception: null

Account and user that placed this order do not exits in OA yet, in BA there are unprocessed/failed tasks for this account creation.

Cause

The issue is caused by #APS-38676 ("7.0.1: pem.addAccount makes call to BA API to update account").

Resolution

To provision the orders it is required to process the tasks for account and user creation:

  • For account creation, go to Operations > Tasks, fill in the new account ID in Parameters and check the corresponding event tasks
  • For user creation, take the user ID from the user created under the new account, go to Operations > Tasks and fill in the user ID in Parameters.

To completely avoid the issue, install OA 7.0 Update 1.

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