Search Engine: Elastic

Article ID: 129740, created on Oct 29, 2016, last review on Oct 29, 2016

  • Applies to:
  • Operations Automation

Symptoms

Incorrect or duplicate DNS records are returned for a domain, for example:

host -ta domain.tld
11.11.11.11
12.12.12.12

I expect it to return only 11.11.11.11. Why does it return 12.12.12.12?

Cause

  1. External, i.e. not controlled by OA, DNS servers are used to manage domain zone
  2. Additional record was manually added to domain zone from OA control panel
  3. Additional record is present in zone file of domain on DNS server

Resolution

  1. Check which NS servers return DNS records for the domain using commands like:

    whois domain.tld
    host -tns domain.tld
    dig +trace domain.tld
    

    If name servers used are not OA-managed name servers then zone configuration should be checked on that DNS server directly.

  2. Check records that are present for this domain in OA via Provider control panel > Operations Director > DNS Manager > Domains > domain.tld > DNS > DNS records. Records that have type = System are added by OA automatically when particular hosting is added to domain (A record for website to resolve to IP of web server, MX record pointing to mail server, etc). Records that have type = Manual are ones added manually by user. If incorrect record exists and has type = Manual, it can be disabled or removed.

  3. If in OA control panel it only shows correct records then we should check records directly on DNS server to see if there is wrong record there.

    • For PowerDNS server:

      • Enter PowerDNS database:

        psql -Upowerdns -h`hostname`
        
      • Execute command:

        SELECT d.name AS "domain name", r.name, r.type, r.content FROM domains INNER JOIN records r ON (r.domain_id = d.id) where r.name ILIKE '%domain.tld%'
        
    • For Bind server:

      find /var/named/run-root/var/ -type f |xargs grep domain.tld
      

    If it was found that duplicate record exists in zone of domain.tld or in zone of another domain then to fix it you can make OA regenerate domain zone for this domain:

    • go to OA Provider control panel > Operations Director > DNS Manager > Domains > domain.tld > DNS > Change DNS hosting to external.

    • Go to task manager and process tasks to update name servers (please note that at this point all DNS records for the domain will be removed from DNS servers and will not be available so it is better to do this outside of business hours)

    • go to OA Provider control panel > Operations Director > DNS Manager > Domains > domain.tld > DNS > Change DNS hosting to internal (this will schedule tasks to add domain and all its records that are configured for it in OA to DNS servers)

    • Go to task manager and process tasks to update name servers

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