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Article ID: 129460, created on Sep 18, 2016, last review on Jan 3, 2018

  • Applies to:
  • Operations Automation 7.2
  • Operations Automation 6.0

Symptoms

On attempt to place an Order directly in BA PCP the following error appears:

Internal error: APSC: Resource for service template 53 not found...
Error Code: 0xb619b247. Report ID: 191210

Service Template exists and delegated to Reseller. Configuration seems to be correct.

core.log error message:

Method 'pem.APS.getServiceTemplateToken' is executed, with status: { 'error_message' => 'Internal error: APSC: Resource for service template 53 not found..', 'extype_id' => 1, 'module_id' => 'Common', 'properties' => { 'reason' => 'APSC: Resource for service template 53 not found.', }, 'status' => -1, }

The following RQL query returns empty result:

# curl -kE /usr/local/pem/APS/certificates/poa.pem 'https://localhost:6308/aps/2/resources?limit(0,1),serviceTemplateId=eq=53,implementing(http://parallels.com/aps/types/pa/serviceTemplate/1.1)'

Cause

Corresponding APS resource of type /pa/serviceTemplate is absent.

Resolution

  • For Odin Automation 6.x platform version:

Manually propagate Reseller's account resources via the following command:

# /usr/local/pem/bin/saas_ctl sync_account $reseller_ID no

Please note 'no' parameter - it disables recursive propagation since it may lead to delays or even outage of provisioning system and should be used only during non-business hours.

  • For Odin Automation 7.x platform version:

    Please contact Odin Technical Support to recreate /pa/serviceTemplate APS resource manually.

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