Search Engine: Elastic

Article ID: 129456, created on Sep 16, 2016, last review on Nov 10, 2017

  • Applies to:
  • Operations Automation 7.0
  • Operations Automation 7.1

Symptoms

Provisioning "Panel_6_1" for APS application Plesk in VPS Panel task fails with the following error after an upgrade to 7.0 version of OA:

APS Application Error:
500 Internal Server Error
[ApplicationUnknownError] Internal Server Error: Can't find schema for "http://www.parallels.com/aps/plesk/configuration/1.100".

Or the following error in case OA was already upgraded to 7.1:

APS Application Error: 
500 Internal Server Error
[Pvps::App::Panel::Exception::RuntimeException] Internal Server Error: Unable to find the proper release ID for Server parameters:

The following messages can be found in /usr/local/share/aps/<uuid>/var/log/pvps-panel.log inside the VE, where Plesk is getting installed:

[Sep,05 10:35:54][LVQ_1473071752][INFO][provision]: Setting state: 'COPY_CONFIGURATION#CHECK' with status: 'failed'...
[Sep,05 10:35:54][LVQ_1473071752][ERR][provision]: Provision state execution failed
state: COPY_CONFIGURATION#CHECK
exception: exception 'APS\SchemaException' with message 'Can't find schema for "http://www.parallels.com/aps/plesk/configuration/1.100".' in /usr/local/aps/60fce2a9-fbca-406a-848b-f09ba699d618/vendors/php-runtime/aps/2/types.php:322
Stack trace:
#0 /usr/local/aps/60fce2a9-fbca-406a-848b-f09ba699d618/vendors/php-runtime/aps/2/types.php(558): APS\TypeLibrary::getSchemaByTypeId('http://www.para...')
#1 /usr/local/aps/60fce2a9-fbca-406a-848b-f09ba699d618/vendors/php-runtime/aps/2/types.php(727): APS\TypeLibrary::parseResourceJSON(Object(com\parallels\www\aps\plesk\configuration\Configuration), Object(stdClass))

The same error is faced during DNS de-sync, CCP shows that the operation completes successfully, but /usr/local/share/aps/<uuid>/var/log/pvps-dns.log contains:

[Nov,21 17:05:29][VFP_1479747929][ERR][APS DNS DELETE]: Class \com\parallels\www\aps\plesk\configuration\v1\v100\LicenseAttributes doesn't exist. Can't load it.

Cause

Old Plesk in VPS APS applications versions cause the task failures during provisioning of new PVPS subscriptions. The issue will be corrected in scope of CCU-13343 request.

Resolution

  1. Disable all old versions of Plesk in VPS Panel and Plesk in VPS Cloud applications (1.1 / 1.2 / 1.3 / 1.100 / 1.300).

  2. Remove the old PVPS APS type cache from the OA Management Node:

    # rm -rf /var/www/pvps/www/parallels-plesk-cloud/typeCache
    

In case the solution does not help, contact Odin Technical Support for further analysis.

5356b422f65bdad1c3e9edca5d74a1ae caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07 0871c0b47b3b86ae3b1af4c2942cd0ce 1941880841f714e458ae4dc3d9f3062d 8c199f0ee4305da1a577740620df4a51

Email subscription for changes to this article
Save as PDF