Symptoms
Customer changed some DNS records in Plesk, but those changes did not propagate to OBAS.
Cause
The following messages are displayed in /var/log/hspc/hspc.log
:
2015/11/07 13:07:23] [DEBUG] [3304] [HSPC::MT::Plesk::DNS::can_create_domain] TRACE [04]: . . . -> HSPC::MT::Plesk::DNS->can_create_domain (domain => domain.tld; account_no => 2) => ERROR: existing domain ERROR: foreign subdomain
[2015/11/07 13:07:23] [DEBUG] [3304] [HSPC::MT::Plesk::DNS::update_domain_zone] Could not create domain domain.tld
Domain Registration and related Plesk Domain subscriptions are owned by different accounts.
Resolution
Make both subscriptions to be owned by one and the same account:
- Go
Top > Account Director > Subscription Manager > Subscriptions > domain.tld > General Settings
- Press Change Account button, choose the correct account in a window that appears and follow the wizard.
Related articles:
Domain’s DNS zone is not synchronized with Plesk: "ERROR: foreign subdomain"