Article ID: 122806, created on Sep 8, 2014, last review on Dec 29, 2016

  • Applies to:
  • Odin Business Automation Standard

Symptoms

It is not possible to access the Provider's Control Centre.

One of the the following messages is displayed:

Unfortunately, the application you are trying to access is unavailable. 

or

 Service Unavailable 

The following errors are in /var/log/hspcd/error_log:

ERROR: Date::Manip unable to determine TimeZone
sh: /dev/null: Permission denied

Cause

The issue is caused by a Perl module Date::Manip that could not be loaded due to insufficient permissions on /dev/null file. When you open the control panel this module is loaded to check timezone settings.

To reproduce the issue on the host manually please try to open module by hand:

[root@vps ~]# perldoc Date::Manip
/usr/bin/nroff: line 6: /dev/null: Permission denied
/usr/bin/nroff: line 52: /dev/null: Permission denied
/usr/bin/nroff: line 68: /dev/null: Permission denied
/usr/bin/lesspipe.sh: line 52: /dev/null: Permission denied

Resolution

Verify that correct permissions are set for /dev/null. It should be 0666.

400e18f6ede9f8be5575a475d2d6b0a6 caea8340e2d186a540518d08602aa065

Email subscription for changes to this article
Save as PDF