Article ID: 122421, created on Jul 21, 2014, last review on May 9, 2017

  • Applies to:
  • Business Automation

Symptoms

Order is placed (or automatically generated) without any order details or with some details while others are missing. As a result, the notification the customer received does not have these details as well. Why?

Cause

The main reason is zero price of the details that are not displayed.

  1. The fee (recurring/setup) for the subscription/resource is zero and an option "Show Zero Price" is set to "No" in the Plan - Subscription Period configuration.
  2. The promotion which sets zero price and overrides plan option 'Show Zero Price" is applied during Plan purchase.
  3. In case if a resource detail is missing, it is possible that a Resource Rate has a Resource Rate Period configured with "Show Zero Price Option" set to "No".

Resolution

  1. Set "Show Zero Price" for the subscription fee to "Yes":

    Home > Products > Service Plans > #ID PlanName > Subscription Period #ID

    or for the resource:

    Home > Products > Service Plans > #ID PlanName > Resource Rate #ID ResourceName

  2. Set "Show Zero Price" for the subscription (recurring) fee to "Yes" in the promotion:

    Home > Products > Marketing > Promotion Name > Promoted Plan Name

    or for the resource:

    Home > Products > Marketing > Promotion Name > Promoted Resource ResourceName

  3. Set "Show Zero Price" to "Yes" for a Resource Rate period:

    Home > Products > Service Plans > #ID PlanName > Resource Rate #ID ResourceName > Resource Rate Period #ID

An option change is applied only on the new sales.

For existing subscription synchronization with the service plan is required (options "Update Prices", "Update Limits" for resources and "Not Install" on "Install into Provisioning System").

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