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Article ID: 122308, created on Jul 9, 2014, last review on Sep 21, 2016

  • Applies to:
  • Plesk Automation 11.5

Symptoms

Task Configure IP Address fails with error:

    Queue name: ip_addr_on_host_5

    Task name: Configure IP address on host qwe(5)

    Method name: taskConfigureIP on SCREF:SDK::IPAddress:0

    Last execution output: Destination host 'qwe' (#5), IP '1.2.3.4' : Internal error: The specified network resource or device is no longer available. (0x0).

Cause

Network Adapter GUID was changed on Service Node.

Resolution

  1. Connect to PA database (from PA Management node):

    # psql -U plesk -h `hostname` plesk
    
  2. Check network adapter GUID with command below on Service Node:

    C:\Users\Administrator>net config rdr
    Computer name                        \\qwe
    Full Computer name                   qwe
    User name                            Administrator
    
    Workstation active on
            NetBT_Tcpip_{12345F-1615-45A8-123C-003CA3A5789B}
    
  3. Compare GUID with GUID in plesk database:

    plesk=> select * from net_interfaces where host_id=5;
     if_id | host_id |                if_name                 |    if_description
    -------+---------+----------------------------------------+-----------------------
        5  |       5 | {CB054B02-2E2F-4978-887B-BC7315B48507} | Local Area Connection
    

    Note: host_id is id of Service Node under Hosting Provider CP > Infrastructure > Service Nodes.

  4. GUIDs should be the same. If they are different, update it in PA database as below:

    plesk=> begin;
    BEGIN
    plesk=> update net_interfaces set if_name='{12345F-1615-45A8-123C-003CA3A5789B}' where host_id=5;
    UPDATE 1
    plesk=> commit;
    COMMIT
    

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