Search Engine: Elastic

Article ID: 119870, created on Jan 29, 2014, last review on Dec 29, 2016

  • Applies to:
  • Odin Business Automation Standard 4.5

Symptoms

I update "iopslimit" limit for a container through OBAS:

Top > Service Director > Virtuozzo Manager > Containers > %container% > Configuration > Edit

According to OBAS log new limit is passed to the VZ node (/var/log/hspc/vzagent.log):

[Tue Jan 28 08:29:18 2014] 28187: > 123.123.123.123 VZAgent
<packet id="5" version="4.0.0" xmlns:ns1="http://www.swsoft.com/webservices/vza/4.0.0/vzatypes" xmlns:ns2="http://www.swsoft.com/webservices/vzl/4.0.0/backupm"     xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
  <data>
    <vzaenvm>
      <set>
        <config>
...
          <qos>
            <hard>3333</hard>
            <id>iopslimit</id>
            <soft>3333</soft>
          </qos>
...
        </config>
        <eid>74a8e451-a143-c24e-ac8a-9d0f2bb1a833</eid>
        <set_mode>restart</set_mode>
      </set>
    </vzaenvm>
  </data>
  <target>vzaenvm</target>
</packet>

Where 123.123.123.123 is IP Address of VZ node where the container resides. But the limit was not updated for the container in VZ node:

[root@hw_node ~]# cat /vz/private/%ve_id%/.vza/eid.conf
74a8e451-a143-c24e-ac8a-9d0f2bb1a833
[root@hw_node ~]#
[root@hw_node ~]# vzlist -octid,iopslimit %ve_id%
      CTID  IOPSLIMIT
      %ve_id%          -
[root@hw_node ~]#

Cause

Outdated VZAgent is installed on the hardware node where the container resides.

Resolution

Upgrade VZAgent on the hardware node to the latest version.

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