Article ID: 119833, created on Jan 27, 2014, last review on Oct 20, 2016

  • Applies to:
  • Operations Automation 6.0
  • Operations Automation 5.5

Symptoms

The following is true:

  • A domain is not In Sync in the Customer Control Panel (CCP).
  • The domain is Active in the Plesk Control Panel (CP).
  • Domain tasks have completed successfully in the Plesk CP.

On resubmitting to the Plesk CP, the following error occurs:

Failed to Add 
Parallels Plesk Panel (id=<ID>) is not ready to perform operation

Cause

Plesk was not initialized correctly due to a bug in Operations Automation (OA). This is either POA-71208 (in OA 5.4) or POA-81145 (in OA 5.5, but less than 5.5.3) or POA-82214 (in OA 5.5, but less than 5.5.4).

Resolution

Provided that everything is correct inside Plesk, the following solution can be used:

  1. Check that the 'operations' field for this Plesk instance has a value of 4 (the following queries should be run in the OA database on the OA Management Node):

    plesk=> select operations from psa where id=<ID>;
    operations
    ----------
    4
    (1 row)
    ----------
    

(Where <ID> is the <ID> from the error message.)

  1. Reinitialize Plesk: Home > Plesk Panel Reinitialize button.

    If the Reinitialize button is not available, use the following query in the POA database:

    plesk=> update psa set operations = 15 where id=<ID>;
    
  2. Resubmit the domain to Plesk, which should restore its sync state.

caea8340e2d186a540518d08602aa065 5356b422f65bdad1c3e9edca5d74a1ae e12cea1d47a3125d335d68e6d4e15e07 5b048d9bddf8048a00aba7e0bdadef37 2554725ed606193dd9bbce21365bed4e 956c448bddc7e1f3585373687602379f 6f1456866eed87488c0f02b298a741c0

Email subscription for changes to this article
Save as PDF