Symptoms
The following notification is shown in OBAS Provider's Panel (http://%pbas.name%/hspc/pcc
):
Parallels Business Automation - Standard license update has been failed.
Using instructions from this KB I've verified that ka.odin.com is resolved correctly, all ports are opened and connection to ka.odin.com:5224 from the OBAS node is possible.
Cause
It's by design that license key update is possible after "License Update Date - license key property.
For current OBAS license key the update data ("License Update Date") is in the future:
Top > Configuration Director > License Manager > Parallels Business Automation - Standard Licenses > Management Node
---8<---
License Update Date 21-Dec-2013
--->8---
Debug OBAS log gives "License key is not prolongated yet" on license key request:
[2013/12/20 17:22:28] [DEBUG] [6984] [HSPC::LM::MN::Update::update_license] request to KA: <?xml version="1.0" encoding="UTF-8"?><methodCall><methodName>pkp13.getKey</methodName>
…
[2013/12/20 17:22:29] [DEBUG] [6984] [HSPC::LM::MN::Update::update_license] response from KA: <struct><member><name>resultCode</name><value><int>2</int></value></member><member><name>resultDesc</name><value>
<string>License key is not prolongated yet</string></value></member><member><name>detailResultCode</name><value><int>2021</int></value></member></struct>
Resolution
The license key will be updated automatically after "License Update Date".