Search Engine: Elastic

Article ID: 118930, created on Nov 29, 2013, last review on Jun 23, 2014

  • Applies to:
  • Operations Automation

Symptoms

After upgrading to 5.4.14, webmail stops working. This message is shown after a successful login:

"This page was disabled by security reason. You can log into webmail using POA CP or url like 'webmail.yourdomain'."

All tests from KB article #6602 are successful.

Cause

Horde requires the PHP4 module to run but, after the upgrade, PHP5 is added to the pem httpd config:

~# cat /usr/local/pem/etc/apache/httpd.conf_pem.phpmodule
LOADMODULE php5_module modules/libphp5.so

Resolution

Check that PHP4 is installed:

~# rpm -qa | egrep "php4-4.4.9-7.pem|php53-5.3.3"
php53-5.3.3-13.el4.pem
php4-4.4.9-7.pem

Change the pem httpd config so that it uses the PHP4 module:

~# cat /usr/local/pem/etc/apache/httpd.conf_pem.phpmodule
LOADMODULE php4_module modules/libphp4.so

It may be necessary to configure the specific Apache configuration as described in the Resolution part of KB article #116089. This ensures changes persist through reboots of the node.

5356b422f65bdad1c3e9edca5d74a1ae caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07

Email subscription for changes to this article
Save as PDF