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Article ID: 118286, created on Oct 30, 2013, last review on Nov 22, 2017

  • Applies to:
  • Operations Automation
  • Business Automation

Symptoms

An attempt to change the option "Charge for subscription" or "Billing Period" in the service plan delegated to the reseller(s) results in the error:

This Plan has been delegated to Resellers. You are not allowed to modify Recurring Type.
This Plan has been delegated to Resellers. You are not allowed to modify Billing Period Type.

Cause

It is not possible to change an option for the delegated plans, there is a request to allow it - #PBA-13939 ("Change option 'Charge for Subscription' for delegated plan").

It is correct system behavior that billing period shall not be changed for the plans that are delegated to the reseller. The restriction is explained by the fact that the reseller is billed by the settings that are defined in the provider's service plan, which means the changes in billing for the reseller are made "on a fly" - as soon as the change on the providers plan is done (if it had been possible), so the reseller would be billed some price for 1 month, while all the resellers customer would be billed the same price for a year. Moreover, possibility of option change can cause unexpected billing of the existing subscriptions".

Resolution

  1. Create a new plan/clone existing, but change the setting.
  2. Delegate new plan to the Resellers which require changes (modify Reseller's Service Template settings and synchronize Resellers).
  3. Login to the BA Control Panel under each Reseller, make sure the new plan appeared in the list of plans.
  4. In Reseller's Control Panel configure an upgrade path from the old delegated plan to a new one: https://download.automation.odin.com/pa/6.0/doc/portal/6.0/ba/75702.htm
  5. Switch customers' subscriptions from the old service plan to a new one by placing plan switch orders.

Additional notes

It is currently impossible to switch from "Before Billing Period" (BBP) Plan to "After Billing Period" (ABP) Plan and vise versa. These plans utilize completely different Billing Model, and there is no automated way to recalculate subscription prices and convert periods.

A feature request with ID PFR-752 (Switch plans from prepaid to postpaid and vice versa) has been submitted to Odin developers to implement such functionality.

See also

There is also a way to get the error message:

This Plan has been delegated to Resellers. You are not allowed to modify Billing Period Type.

This behavior is described in the KB131808.

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