Symptoms
Notification "...tasks have failed since..." is shown at the top of Provider's Panel (PCC):
But I do not see as many failed tasks when I click button "See the details on the Task Manager page". Why?
Cause
It's by design that only tasks with status "Error" are shown in OBAS when you click the "See the details on the Task Manager page" link:
The counter in the notification above includes failed tasks in both "Error" and "Timeout" statuses.
Resolution
To see additional failed tasks on the Tasks Queue
page click "Show Search" in the top right corner of the screen and select "Timeout" in the drop down "Search" menu.