Symptoms
We tried to register the domain DOMAIN.TLD in PBA-S. The domain has the status Registering, doesn't appear on Enom and when we click on Check Status the following error is returned:
Top > Service Director > Domain Manager > Domains > DOMAIN.TLD > Check Status
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Domain status check failed: Plugin return error: .
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The following error is shown in debug PBA-S log:
/var/log/hspc/hspc.log
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[2013/07/26 08:02:53] [INFO] [17833] [HSPC::MT::Plugin::DM::eNom::Transport::call_enom] [enom]Sending command: http://reseller.enom.com/interface.asp?uid=dfdfdfdf&pw=xxxxxx&Command=GetDomainStatus&sld=DOMAIN&tld=TLD&orderID=234318161&OrderType=purchase
[2013/07/26 08:02:54] [INFO] [17833] [HSPC::MT::Plugin::DM::eNom::Transport::_parse_plain] Parsed result: $VAR1 = [
'command => GETDOMAINSTATUS',
'domainname => DOMAIN.TLD',
'done => true',
'errcount => 0',
'exectime => 0.094',
'inaccount => 0',
'islockable => False',
'isrealtimetld => False',
'language => eng',
'maxperiod => 1',
'minperiod => 1',
'orderid => 234318161',
'requestdatetime => 7/26/2013 12:02:55 AM',
'responsecount => 0',
'server => server1234',
'site => eNom',
'statusdesc => Invalid Contact Extended Attributes',
'timedifference => +3.00',
'trackingkey => 9d21c825-8928-423e-ac6e-ff3c581cc732'
];
...
[2013/07/26 08:02:54] [DEBUG] [17833] [HSPC::ErrorStack::set_last_error] [ErrorStack]: 3276848 Domain status check failed: Plugin return error: .
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Cause
The error means that domain status check failed because of error "Invalid Contact Extended Attributes" returned by Enom. It's believed that certificate request (CSR) for DOMAIN.TLD is invalid - is cannot be processed by the registrar because of the error.
Resolution
Contact Enom directly and request for information about the error: why they consider Contact Extended Attributes is invalid for DOMAIN.TLD. If they confirm CSR was invalid and provide the details how valid request should look like, you should generate the CSR and place the order anew.
Since existent orders of SSL certificate cannot be modified through PBA-S, you'll need to cancel existent order and create new one with valid CSR.