Article ID: 117306, created on Sep 17, 2013, last review on Nov 1, 2016

  • Applies to:
  • Odin Business Automation Standard 4.5

Symptoms

A renewal order was not generated for an SSL certificate subscription. Option Generate renewal orders and try to pay them automatically is set under Top > Account Director > Subscription Manager > Subscriptions > <subscription_name>. The subscription is in Graced status.

Cause

An SSL certificate for affected subscription was not provisioned completely and Expiry date value was not set.

As a result, during Recurring payment process along with Invoice and Statements creation procedure task execution OBAS finds Expiry date to be empty and therefore skips generation of the renewal order.

The following messages are displayed in /var/log/hspc.log:

[2016/09/22 18:55:44] [DEBUG] [5407] [HSPC::MT::SSL::can_renew_certificate] date_expired not defined, certificate not finished, can't renew
[2016/09/22 18:55:44] [DEBUG] [5407] [HSPC::MT::BM::Subscription::SSL::can_renew] TRACE [05]: . . . . -> HSPC::MT::BM::Subscription::SSL->can_renew () =>  NO
[2016/09/22 18:55:44] [DEBUG] [5407] [HSPC::MT::Billing::Subscription_base::is_renewable] TRACE [04]: . . . -> HSPC::MT::Billing::Subscription_base->is_renewable (subscr_id=>35479)

Resolution

Please contact Odin Technical Support for assistance.

Search Words

Expiry date

Are you sure you want to try issuing the SSL certificate again?

SSL certificate was not reissued

renewal order was not generated

generate

ssl certificate not visible after purchase

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