Article ID: 117164, created on Sep 6, 2013, last review on Sep 29, 2015

  • Applies to:
  • H-Sphere 3.6.2
  • H-Sphere 3.6.3

Symptoms

Reseller account was cancelled, but end-user belonging to this account cannot be removed:

You have no permissions on this plan

Cause

Access for the plan 'Administrative account', assigned to the reseller is not possible from control panel.

Resolution

  1. Log in to the H-Sphere database.

  2. Get ID for plan 'Administrative account' assigned to the reseller:

    hsphere=> SELECT * from plans where reseller_id = 20706;
      id   |      description       | disabled | billing | cinfo | reseller_id | deleted | is_base | base_id
    -------+------------------------+----------+---------+-------+-------------+---------+---------+---------
     14040 | Windows Ultimate       |        0 |       0 |     1 |       20706 |       0 |         |
     14054 | Unix Ultimate          |        0 |       0 |     1 |       20706 |       0 |         |
     14035 | Administrative account |        0 |       0 |     0 |       20706 |       0 |         |
    (3 rows)
    
    hsphere=> SELECT * from plan_access where id=14035;
      id   | a_id
    -------+------
     14035 | 8572
    (1 row)
    
  3. Remove found record from plan_access table:

    hsphere=> begin;
    BEGIN
    
    hsphere=> delete from plan_access where id = 14035;
    DELETE 1
    
    hsphere=> SELECT * from plan_access where id=14035;
     id | a_id
    ----+------
    (0 rows)
    
    hsphere=> commit;
    COMMIT
    
  4. Restart H-sphere service

    service httpdcp restart

  5. Re-try deleting the account.

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