Article ID: 117086, created on Sep 4, 2013, last review on Jan 16, 2017

  • Applies to:
  • Operations Automation
  • Business Automation

Symptoms

An attempt to switch from Operations Automation (OA) to Business Automation (BA), access the "Account" tab in the Customer Control Panel, or use any billing-related link for a particular account causes an error:

Fatal error An unforeseen error occurred. Please contact support@provider.com.
Error ID: <date_in_unix_format>

or

Billing is not available right now 

Also, the BA login page may be shown.

Meanwhile, access for other accounts works fine.

On the BA application server in the www.log file (located by default in the /usr/local/bm/log folder on Linux or the C:\Program Files\Parallels\PBA\log folder on Windows), the following error appears:

[13-08-07 17:27:55.905 UIWorker    RQ100985 WRN] Login or Password is incorrect.

Cause

There is a login/password discrepancy between OA and BA for the staff member used to log into the Provider Control Panel or Customer Control Panel.

Resolution

  1. If the login names are different in OA and BA, update the user's login name in BA with the UserUpdate_API API method call to match the login name in OA. Refer to the Public API Reference for details.

    You can also find examples of the request and its response in our documentation.

  2. Reset the password for the staff member in OA or BA to create matching passwords in both systems.

    To reset the password for a staff member in OA:

    For a client's staff member:

    Operations Director > Customer Manager > Customers > [select Account] > General > Staff members > [select staff member], click the 'Edit' button.

    For a provider's staff member:

    Configuration Director > Security Manager > Users > Staff Members > [select staff member], click the 'Edit' button.

    To reset the password for a staff member in BA:

    For a client's staff member:

    Operation Director > Account Manager > Customers > [select Account] > Users > [select staff member], click the 'Change Password' button.

    For a provider's staff member:

    Configuration Director > Security Manager > Users > [select staff member], click the 'Change Password' button.

  3. It is also possible that the created user has a trailing space in its username in BA, but this has been trimmed from the username in OA. In this case, an update to the BA database is required. Please contact the Odin Technical Support Team to make this update.

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