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Article ID: 113995, created on May 29, 2012, last review on Apr 14, 2017

  • Applies to:
  • Odin Business Automation Standard 4.5

Symptoms

A Plesk node is up and running, but it is shown with the status "Not Available" in the Odin Business Automation Standard (OBAS) Panel (Top > Service Director > Plesk Manager > Nodes).

Cause

Various issues can cause the above problem, including:

  • Network connectivity issues
  • An expired Plesk license
  • The Plesk admin’s password was changed directly from the Plesk Control Panel
  • The IP Address of the OBAS node has been changed
  • A broken API-RPC package on Plesk
  • Firewall rules that prevent OBAS from connecting to the Plesk node

Resolution

  1. Make sure that Plesk is functioning properly: see more help on Plesk for Linux or Plesk for Windows.

  2. Log into the Plesk Control Panel and check that a valid license is installed.

  3. Make sure that the IP address of the Plesk server is reachable from the OBAS server and that the connection to port 8443 is not blocked on either the Plesk server or the OBAS server.

    To check the OBAS connection, log in on the OBAS server via SSH. Check the connection of the Plesk server (IP 123.123.123.10 ) on port 8443 with the telnet command:

    # telnet 123.123.123.10 8443
    Trying 123.123.123.10...
    Connected to 123.123.123.10.
    Escape character is '^]'.
    
  4. Get the admin password for Plesk for Linux or Plesk for Windows and update it in OBAS:

    Top > Service Director > Plesk Manager > Nodes > %Plesk node% > Edit > Plesk administrator password

    This will re-initiate secure keys for further communication. NOTE: The connection may fail because of the Plesk Security Policy.

  5. Run the periodic task "Update Plesk nodes stats info" from the OBAS Provider Control Panel to update the Plesk node's status:

    Top > Configuration Director > Logging and Errors > Action Log > Task Queue tab > Update Plesk nodes stats info > Run now

    Verify DEBUG OBAS log for update records. NOTE: The task may fail because of error "PleskAPIInvalidSecretKeyException : Invalid secret key usage. Please check logs for details."

  6. By design, OBAS communicates with Plesk using the Plesk API. Check the consistency of the API-RPC-related packages on the Plesk server:

    • Linux

    Validate the package psa-api-rpc:

    # rpm -V psa-api-rpc
    

    The above command will give you a list of missing or modified files, if there are any. If the output is not empty, it most likely means that the package needs to be reinstalled.

    The valid package can be obtained from http://autoinstall.plesk.com (according to your Plesk version, OS, and architecture) and reinstalled. The example given below illustrates the installation of the psa-api-rpc package of Plesk 11.5.30 installed on a server with CentOS 6 x64.

    # wget http://autoinstall.plesk.com/PSA_11.5.30/dist-rpm-CentOS-6-x86_64/contrib/psa-api-rpc-10.0.0-1.noarch.rpm
    # rpm -Uvh --force psa-api-rpc-10.0.0-1.noarch.rpm
    

    Once the package is reinstalled, run the task "Update Plesk nodes stats info" in OBAS again, following Step 4 (above).

    • Windows

    There is no simple way to reinstall a single package on Windows. The files in question are located in the %plesk_dir%\admin\plib\api-rpc directory.

    Check that the files in this directory, specifically Agent.php, were not changed after the installation/upgrade, and that they have the correct permissions:

    psaadm: Read, Read&execute
    
  7. Temporarily disable the firewall on the Plesk node and recheck the node's availability. Make sure that the firewall rules do not disappear after restarting iptables. If it turns out that firewall is the key, please review the firewall rules and modify them so that all the required ports are open.

See also

Plesk node is Not available

Error: empty data received from PleskAgent -- networking

Plesk nodes are Not Available after OBAS server migration

Available Plesk node is in Unregistered state

Plesk Clients became Absent on Plesk

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