Symptoms
Hosted Exchange Autodiscover/ActiveSync services do not work:
1. Customer is getting an error in their smartphone that the password is not valid.
2. POA CCP shows unforeseen error at Top > Exchange > Mailboxes
3. Trying to reconfigure the device POA CCP shows the same unforeseen error of error about invalid password.
Autodiscover URL (https://autodiscover.provider.com/Autodiscover/Autodiscover.xml) gives error message:
500 System.Net.WebException: The operation has timed out at System.Net.HttpWebRequest.GetResponse() at AutodiscoverProxyHandler.Handler.ProcessRequest(HttpContext context)
Event Viewer on Exchange CAS servers shows error like this:
WebHost failed to process a request.
Sender Information: System.ServiceModel.Activation.HostedHttpRequestAsyncResult/55761063
Exception: System.UriFormatException: The protocol binding '[::1]:80:' does not conform to the syntax for 'http'. The following is an example of valid 'http' protocol bindings: ':80:'.
at System.ServiceModel.AsyncResult.End[TAsyncResult](IAsyncResult result)
at System.ServiceModel.Activation.HostedHttpRequestAsyncResult.End(IAsyncResult result)
Process Name: w3wp
Process ID: 9896
Cause
Wrong binding
[::1]:80: is configured on the default website in IIS on CAS servers. It was probably added by some Exchange update.
Resolution
Remove wrong binding
[::1]:80: from the default website in IIS on CAS servers.