• Article for your preferred language does not exist. Below is international version of the article.

Article ID: 3191, created on Nov 30, 2007, last review on May 9, 2014

  • Applies to:
  • H-Sphere

Resolution

 

PHP Modules Enabled in Standard PHP Installation


Function Reference
(or PHP extensions)
H-Sphere 2.4.x
(apache-webbox)
H-Sphere 2.5 and up, php4 H-Sphere 2.5 and up, php5
before 4.4.4 4.4.4 + before 5.1.6 5.1.6 +
bcmath core so so so so
bz2 core so core so core
calendar core so so so so
ctype core core core core core
curl core so so so so
date - - - core core
dba - core core core core
dbase - so so so so
dbx - so so - -
dom - - - core core
domxml - so so - -
exif - so so - so
fileinfo - so so so so
filepro - so so so so
ftp core so core so core
gd core so core so core
gettext core so core so core
gmp - so so so so
hash - - - core core
iconv core so so so so
imap core so so so so
ldap - core so core so
libxml - - - core core
mbstring core core core core core
mcal - so so - *1
mcrypt core so core so core
mhash core so core so core
mime_magic - core core core core
mnogosearch core so so so so
mysql core so so so so
ncurses - so so so so
odbc - so so so so
openssl core core core core core
overload core core core - *2
pcntl - so so so so
pdf - so so - -
pcre core core core core core
PDO - - - core core
pgsql core so so so so
posix core core core core core
pspell - so so so so
Reflection - - - core core
session core core core core core
shmop - so so so so
SimpleXML - - - core core
soap - - - so so
sockets core core core so core
SPL - - - core core
sqlite - so so core so
standard core core core core core
swf so removed - -
sysvmsg - so so so so
sysvsem - so so so so
sysvshm - so so so so
tokenizer core core core core core
xml core core core core core
xmlrpc - so so so so
xmlreader - - - core core
xmlwriter - - - core core
xsl - - - core core
xslt - so so - -
yp - so so - *3
zip core so core - -
zlib core core core core core

 

Notes:

*1. This extension has been moved to the PECL repository and is no longer bundled with PHP as of PHP 5.0.0.

*2. See the Overloading in PHP 5 page for more information.

*3. This extension has been moved to the PECL repository and is no longer bundled with PHP as of PHP 5.1.0.


 

f213b9fa8759d57bee5d547445806fe7 6311ae17c1ee52b36e68aaf4ad066387

Email subscription for changes to this article
Save as PDF