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Article ID: 114166, created on Jun 20, 2012, last review on Jul 14, 2014

  • Applies to:
  • Operations Automation

Introduction


The article describes known issue with logging to Lync client and ways to troubleshoot and resolve them.

1. Problem with customer computer clock

Symptoms

Lync client shows the error message 'Cannot sign in to Lync because your computer clock is not set correctly.' on try to sign in:



Cause

Client computer clock is not set correctly.

Resolution

Correct the date and/or time on the client computer using the 'Date and Time' in the Windows Control Panel.

If client computer is a member of a Windows Active Directory domain, the time can be synchronized by the following command: w32tm /resync
In order to synchronize time with a time server, execute the command: w32tm /config /syncfromflags:manual /manualpeerlist:<server>
Replace <server> in the command above with IP address or hostname of a time server. You may use public time servers like http://www.pool.ntp.org/en/use.html.



2. Lync server is temporarily unavailable

Symptoms

Lync client shows the error message 'Cannot sign in because the server is temporarily unavailable. If the problem continues, please contact your support team.' on try to sign in:



Cause #1

If 'Automatic configuration' method is selected to configure connection settings in the Lync client, then one of possible reason of failure is the missing DNS records.

Resolution

In order to be sure that the issue is related to Autodiscover, turn off 'Automatic configuration' in the Lync client and specify Lync connection settings manually:
  • Open Tools > Options in the Lync client
  • Select Personal settings and click the 'Advanced' button
  • Select 'Manual configuration' and type the server name. This name can be obtained in the following ways:
    • Open the POA Customer CP and navigate to the Microsoft Lync 2010 tab. Switch to the Configuration > Settings. The shown 'External Server Name' is the required name.
    • Open the POA Provider CP and navigate to the corresponding Lync resource type. Open its Activation Parameters > Global Settings. The 'SIP Access Edge domain name' is the required name.
  • Apply changes in the Lync client and try to reconnect.

If manual configuration works, check the following DNS records:
  • DNS record 'lyncdiscover.<sipdomain>'
    • Open the POA Customer CP and navigate to Hosted Domains
    • Select the required domain and open its DNS tab
    • Check whether the record 'lyncdiscover.<sipdomain>' exists in the list of DNS records in the domain. If it does not exist, add the corresponding record:
      • Click the Add New DNS Record button
      • Select 'CNAME' as DNS Record type
      • Type 'lyncdiscover' in the Domain field
      • Type <Lync Autodiscover FQDN> into the Canonical Name field (<Lync Autodiscover FQDN> is specified in the Global Settings of the Lync resource type).
    • Click Finish.
  • DNS record '_sip._tls.<sipdomain>'
    • Open the POA Customer CP and navigate to Hosted Domains
    • Select the required domain and open its DNS tab
    • Check whether the record '_sip._tls.<sipdomain>' exists in the list of DNS records in the domain. If it does not exist, add the corresponding record:
      • Click the Add New DNS Record button
      • Select 'SRV' as DNS Record type
      • Type 'sip' and select 'tls' for the Service field
      • Specify the <External Server Name>:<External Server Port> as Server Host. These settings can be found in the Customer CP at Microsoft Lync 2010 > Configuration > Settings page or in the Provider CP in the Lync resource type properties > Activation Parameters > Global Settings page: <SIP Access Edge domain name> and <SIP Access Edge port>.
    • Click Finish.
  • DNS record '_sipfederationtls._tcp.<sipdomain>'
    • Open the POA Customer CP and navigate to Hosted Domains
    • Select the required domain and open its DNS tab
    • Check whether the record '_sipfederationtls._tcp.<sipdomain>' exists in the list of DNS records in the domain. If it does not exist, add the corresponding record:
      • Click the Add New DNS Record button
      • Select 'SRV' as DNS Record type
      • Type 'sipfederationtls' and select 'tcp' for the Service field
      • Specify the <External Server Name>:5061 as Server Host
    • Click Finish.
Make sure that the <SIP Access Edge domain name>, <SIP Access Edge port> and <Lync Autodiscover FQDN> global settings are correct in the Lync resource type in POA.

Cause #2

If both custom and automatic configuration methods do not work, the client firewall settings may be the reason of the problem.

Resolution

Check that the following ports are open for outbound connections on the client side:

Port    Protocol
443   TCP (TLS)
443   TCP (PSOM/TLS)
443   TCP (STUN/MSTURN)
3478   UDP (STUN/MSTURN)
5061   TCP (MTLS)

Cause #3

The other reason is that the some Lync servers are turned off or some Lync services are stopped.

Resolution

As Provider make sure that all Lync servers are turned on and the required Lync services are started on the Lync servers.

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