• Article for your preferred language does not exist. Below is international version of the article.

Article ID: 113254, created on Feb 2, 2012, last review on Aug 15, 2014

  • Applies to:
  • Virtuozzo containers for Linux 4.7
  • Virtual Automation 6.0

Prerequisites

This article describes how to register the PVCfL 4.7 node in PBA-S 4.0 and older versions using compatibility mode.

NOTE: If you are running PBA-S 4.1 or a newer version, do not use compatibility mode for node registration.

For instructions on registering Parallels Virtuozzo Containers for Linux 4.6, refer to this article:

111609: How to register a Parallels Virtuozzo Containers for Linux 4.6 node in PBA-S using compat mode

NOTE: WACP works only with compatibility mode. The libraries provided here can be used with PVA Agent 6.0.

For x86_64 nodes:

Follow these steps to register Parallels Virtuozzo Containers for Linux 4.7, 64 bit, in PBA-S:

  1. Make sure the PVA Agent with Parallels Power Panel component is already installed:

    ~# rpm -qa 'pva-pp*'
    

    If it is not listed, you should install it using the pva-setup command.

  2. Make sure the PVA Agent version 6.0 is already installed. Make sure the version is not older than 6.0-2152:

    ~# rpm -qa 'pva-release*'
    

    If you have an older version, you should upgrade it first to PVA 6.0.

  3. Create a vzagent0 user with administrative privileges and create a directory for the user:

    ~# adduser -u 0 -o -g 0 -G 1,2,3,4,6,10 -M vzagent0
    ~# mkdir /home/vzagent0
    
  4. Change the default shell and password for this user:

    ~# chsh -s /opt/pva/agent/bin/vzlcon vzagent0
    ~# passwd vzagent0
    
  5. Download and unzip the compat plugin for PVA:

    ~# wget http://download.pa.parallels.com/pva/6.0/hotfixes/compat/VZAOpCompat_x64.zip
    ~# unzip VZAOpCompat_x64.zip -d /opt/pva/agent/plugins/
    
  6. Install compat control:

    ~# yum install perl-CGI
    ~# rpm -i --force http://download.pa.parallels.com/pva/6.0/hotfixes/compat/analog-5.32-1.5.swsoft.x86_64.rpm
    ~# rpm -i --force http://download.pa.parallels.com/pva/6.0/hotfixes/compat/vzagent-compat-lib-4.0.0-79.swsoft.x86_64.rpm
    ~# rpm -i --force http://download.pa.parallels.com/pva/6.0/hotfixes/compat/vzagent-compat-opcontrol-4.0.0-79.swsoft.x86_64.rpm
    ~# rm -rf /vz/root/1/var/vzagent/tmp
    ~# mkdir -p /vz/root/1/var/vzagent
    ~# ln -s /var/opt/pva/agent/tmp /vz/root/1/var/vzagent/tmp
    ~# vzagent_compat_ctl start
    
  7. Restart PVA:

    ~# pvaagent restart
    
  8. Add compat control to startup:

    ~# ln -s /usr/sbin/vzagent_compat_ctl /etc/init.d/vzagent_compat_ctl
    ~# chkconfig --add vzagent_compat_ctl
    ~# chkconfig vzagent_compat_ctl on
    
  9. Add SSH1 protocol support by changing the /etc/ssh/sshd_config option to Protocol 2,1:

    ~# vim /etc/ssh/sshd_config
    ~# service sshd restart
    
  10. Register Hardware Node in PBAS:

    1. Go to PBAS PCC -> Service Director -> Virtuozzo Manager -> Nodes -> New Node (or choose existing one).
    2. Put the HW Node IP address in the IP address field.
    3. Enter "vzagent0" in the login field
    4. Enter password from p. 4

For i386 nodes:

Follow these steps to register Parallels Virtuozzo Containers for Linux 4.7, 32 bit, in PBA-S:

  1. Make sure the PVA Agent with Parallels Power Panel component is already installed. Make sure the version is not older than 6.0-2152:

    ~# rpm -qa 'pva-pp*'
    

    If it is not listed, you should install it using the pva-setup command.

  2. Make sure the PVA Agent version 6.0 already installed and not older than 6.0-2152:

    ~# rpm -qa 'pva-release*'
    

    If you have an older version, you should upgrade it first to PVA 6.0.

  3. Create a vzagent0 user with administrative privileges and create a directory for the user:

    ~# adduser -u 0 -o -g 0 -G 1,2,3,4,6,10 -M vzagent0
    ~# mkdir /home/vzagent0
    
  4. Change the default shell and password for this user:

    ~# chsh -s /opt/pva/agent/bin/vzlcon vzagent0
    ~# passwd vzagent0
    
  5. Download and unzip compat plugin for PVA:

    ~# wget http://download.pa.parallels.com/pva/6.0/hotfixes/compat/VZAOpCompat_i386.zip
    ~# unzip VZAOpCompat_i386.zip -d /opt/pva/agent/plugins/
    
  6. Install compat control:

    ~# yum install perl-CGI
    ~# rpm -i --force http://download.pa.parallels.com/pva/6.0/hotfixes/compat/analog-5.32-1.5.swsoft.i386.rpm
    ~# rpm -i --force http://download.pa.parallels.com/pva/6.0/hotfixes/compat/vzagent-compat-lib-4.0.0-79.swsoft.i386.rpm
    ~# rpm -i --force http://download.pa.parallels.com/pva/6.0/hotfixes/compat/vzagent-compat-opcontrol-4.0.0-79.swsoft.i386.rpm
    ~# rm -rf /vz/root/1/var/vzagent/tmp
    ~# mkdir -p /vz/root/1/var/vzagent
    ~# ln -s /var/opt/pva/agent/tmp /vz/root/1/var/vzagent/tmp
    ~# vzagent_compat_ctl start
    
  7. Restart PVA:

    ~# pvaagent restart
    
  8. Add compat control to startup:

    ~# ln -s /usr/sbin/vzagent_compat_ctl /etc/init.d/vzagent_compat_ctl
    ~# chkconfig --add vzagent_compat_ctl
    ~# chkconfig vzagent_compat_ctl on
    
  9. Add SSH1 protocol support by changing the /etc/ssh/sshd_config option to Protocol 2,1:

    ~# vim /etc/ssh/sshd_config
    ~# service sshd restart
    
  10. Register Hardware Node in PBAS:

    1. Go to PBAS PCC -> Service Director -> Virtuozzo Manager -> Nodes -> New Node (or choose existing one).
    2. Put the HW Node IP address in the IP address field.
    3. Put "vzagent0" in the login field
    4. Enter password from p. 4

d02f9caf3e11b191a38179103495106f e8e50b42231236b82df27684e7ec0beb 319940068c5fa20655215d590b7be29b 2897d76d56d2010f4e3a28f864d69223 0889ab60fa6494de107aa7338c3c38b6 0c05f0c76fec3dd785e9feafce1099a9 0efe2234e2ce513f2186f26c68447702

Email subscription for changes to this article
Save as PDF