• Article for your preferred language does not exist. Below is international version of the article.

Article ID: 111302, created on May 20, 2011, last review on Nov 25, 2015

  • Applies to:
  • Operations Automation 5.5

Release notes

This KB contains instructions how to upgrade Apache, BIND, and OpenSSL on POA-managed servers to the latest versions.

Instructions for updating EZ templates below contain <ct_id> placeholder. Replace it with ID of container which you are going to update.

Ensure that application repository is setup to point to Parallels updates site (http://download.pa.parallels.com/poa/5.0/RPMS) before upgrade.

Updating brand servers

Perform the following steps on brand servers:

  1. Update OpenSSL, apr, expat packages

    HW node:

    # yum update openssl
    # yum update apr
    # yum update apr-util
    # yum update expat

    EZ template:

    # vzpkg update -p <ct_id> openssl
  2. Update httpd and modssl packages

    HW node:

    # yum update httpd
    # yum update mod_ssl

    EZ template:

    # vzpkg update -p <ct_id> httpd
    # vzpkg update -p <ct_id> mod_ssl

    Verify that both httpd and mod_ssl packages have version "".

  3. Turn off PHP in Apache config

    Comment section LOADMODULE php4_module modules/libphp4.so in file /usr/local/pem/etc/apache/httpd.conf_pem.phpmodule.

  4. Restart httpd

    # service pemhttpd restart

Updating DNS servers

HW node and case the BIND was installed not via Application Templates:

# yum update bind

EZ template:

# vzpkg update <ct_id> -p bind

Search Words


Error: Application template(s) does not exist: Error: bind

update os poa

FREAK flaw


zpkg update -p $CTID updating php53 packages

Upgrade from Apache 2.11 to Apache 2.4

5356b422f65bdad1c3e9edca5d74a1ae caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07 5b048d9bddf8048a00aba7e0bdadef37 2554725ed606193dd9bbce21365bed4e

Email subscription for changes to this article
Save as PDF