Symptoms
The following error is shown when trying to install OBAS:
No products match current OS installation
Cause
There are two possible reasons for such error:
- Operating System (OS) installed is not supported by Odin Business Automation Standard (OBAS).
- Some RPM dependencies cannot be resolved automatically.
Resolution
1. OS installed is not supported by Odin Business Automation Standard (OBAS).
Verify the list of supported operating systems in Installation Guide: Hardware And Software Requirements.
2. Some RPM dependencies cannot be resolved automatically.
Some packages OBAS requires could be not installed or their versions do not satisfy OBAS requirements. In order to fix this issue please do the following:
a) Check the file "/tmp/product_installer.log
" for unresolved dependencies.
For example, the file "/tmp/product_installer.log
" may contain the following entry:
INFO: Package hspc-release-3.3.1-06.07.swsoft has following unresolved dependencies:
openssh-server >= 3.9p1
DEBUG: <=====
WARNING: [Autoinstaller] No record found in the info file. The OS installed or its configuration is not compatible with HSPcomplete requirements
The entry above means that the "openssh-server
" package is either not installed or installed with the wrong version.
b) Install all packages required by OBAS or remove the conflicting packages. In the example above, openssh-server
should be installed.
c) Before you continue with the OBAS installation, you need to remove the following Perl modules:
# rpm -e perl-Digest-MD5 --nodeps
# rpm -e perl-Storable --nodeps
# rpm -e perl-Filter --nodeps
d) Continue OBAS installation according to the Installation Instructions.